Aller au contenu


***** Bienvenue dans le forum MikrOscOpia ! *****
Photo

[ RÉGLÉ ]publication - html - applet java etc ...


  • Ce sujet est fermé Ce sujet est fermé
7 réponses à ce sujet

#1 patrice dx

patrice dx

    Batracien

  • Membre Modérateur
  • 519 messages

Posté 12 octobre 2010 - 10:13

J'ouvre un nouveau sujet pour discussion sur les aspects techniques de la publication de pages sur la revue microscopia.
on n'y traite pas de questions de fond (sur le contenu des articles) mais uniquement des aspects techniques (encodage html, compatibilité avec les navigateurs et les OS, implémentation d'applets etc... ) en vue de la résolution de problèmes rencontrés.

je fais références à quelques remarques faites dans la discussion sur la modération

1. l'encodage html doit se faire dans les standards recommandés par le WWW consortium (http://www.w3.org/MarkUp/). Le problème est que certains logiciels (et spécialement ceux édités par microsoft) ne respectent pas ses standards : il faut par exemple éviter les publications en format html via MSoffice, publisher etc... Un logiciel de génération de page web comme Frontpage ne respecte pas les standards...

2. Il y a des logiciels de création de site web respectant les standards : Dreamweaver de Adobe est un "must" mais c'est un logiciel propriétaire et la licence n'est pas donnée. En licence libre, on peut utiliser Kompozer. Il y en a certainement d'autres, qui sont moins "wysiwyg" ... htmlkit est un bon logiciel mais il y en a certainement d'autres...

3. sur la pageGalster.html :. En ce qui me concerne, c'est à dire sous linux, ubuntu 9.10 (karmic) et firefox 3.6, (une version de développement appelée namoroka) et java 6 installé, il y a des problèmes. le navigateur ne charge pas les images (ou alors en version 2D) ou ... plante carrément. J'essayerai au boulot sous winXP, avec IE et firefox 3.6, avec un java récent.
L'applet est prévu pour internet explorer, écrit en java 1.1 et adapté à des versions anciennes de netscape... je ne sais pas si l'applet fonctionne avec les versions actuelles de java.
J'ai déjà rencontré le cas d'applets java anciens qui ne fonctionnent plus sous des versions récentes de java.
il se peut donc que les problèmes d'affichage ne soient pas dus à l'encodage réalisé par Michel ou Daniel mais à l'applet lui-même, non adapté aux javas récents ou aux navigateurs...
ps : en plus, il faut des lunettes ;-)). Ce commentaire n'enlève rien à l'intéret de la réalisation d'images microphotographiques stéréo... il faut peut être chercher une autre application. (j'ai naturellement visité le site web du concepteur de cet applet, et expérimenté sur d'autres galeries stéréo, ou je rencontre le même problème)

Edit 13/10/2010
(pour éviter d'ouvrir un autre sujet) : l'essai sous winXP, firefox 3.6 est tout à fait positif : la page galster.htm fonctionne normalement.



cordialement,

Modifié par patrice dx, 13 octobre 2010 - 09:48 .
ajout d'information

  • 0

#2 adn25fr

adn25fr

    Purgatorius

  • Ex membre
  • PipPipPipPipPipPipPip
  • 786 messages

Posté 12 octobre 2010 - 12:56

Bonjour,
je vais donner un coup d'oeil à ces recommandations.

Mais il me semble que le plus simple est d'utiliser un logiciel qui les suive.
Actuellement, j'utilise NVU...
(Mais parfois, lorsque le logiciel de génération d'Html ne donne pas les résultats souhaités, j'écris du code directement comme avec un éditeur de texte!)

La page galster.htm fonctionnait normalement avec divers navigateurs lors de sa parution.
Actuellement, pourvu que java soit installé, elle fonctionne bien sous IE8 (les défauts d'affichage d'images liés aux majuscules ont été corrigés)

Sous chrome, le défaut signalé par mPx vient d'erreurs de copie de la version initiale (ou IE8) du code: des balises </script> ne sont pas à leur place...


J'utilise maintenant un autre applet pour montrer des images stéréo (ce qui est, appliqué à la microscopie, le but de l'article galster.htm). Il s'agit du StereoPhotoViewerApplet de Masuji SUTO.
Voici une page qui l'utilise. Pouvez vous faire des tests avec différents navigateurs svp?
http://daniel.nardin...tereoBinoDN.htm
Attention, il faut près d'une minute au premier chargement pour que l'ordinateur construise les imagettes sensibles
Mais l'affichage des fenètres stéréo correspondant à chaque image est ensuite quasi instantanné après clic sur l'image.
Il est possible de choisir dans le menu différents affichages stéréo. J'ai mis en parallèle par défaut.


ps: Connaissez vous les pages microstéréo de cet excellent micrographe qu'est Wim van Egmond?
http://www.microscop...rt98/milli.html
il a choisi la rusticité d'affichage en ne présentant que des anaglyphes mais c'est dommage de fausser ainsi quelque peu le rendu des couleurs.

Cordialement
  • 0

#3 patrice dx

patrice dx

    Batracien

  • Membre Modérateur
  • 519 messages

Posté 12 octobre 2010 - 01:36

Bonjour,
je vais donner un coup d'oeil à ces recommandations.

Mais il me semble que le plus simple est d'utiliser un logiciel qui les suive.
Actuellement, j'utilise NVU...
(Mais parfois, lorsque le logiciel de génération d'Html ne donne pas les résultats souhaités, j'écris du code directement comme avec un éditeur de texte!)

La page galster.htm fonctionnait normalement avec divers navigateurs lors de sa parution.
Actuellement, pourvu que java soit installé, elle fonctionne bien sous IE8 (les défauts d'affichage d'images liés aux majuscules ont été corrigés)

Sous chrome, le défaut signalé par mPx vient d'erreurs de copie de la version initiale (ou IE8) du code: des balises </script> ne sont pas à leur place...


J'utilise maintenant un autre applet pour montrer des images stéréo (ce qui est, appliqué à la microscopie, le but de l'article galster.htm). Il s'agit du StereoPhotoViewerApplet de Masuji SUTO.
Voici une page qui l'utilise. Pouvez vous faire des tests avec différents navigateurs svp?
http://daniel.nardin...tereoBinoDN.htm
Attention, il faut près d'une minute au premier chargement pour que l'ordinateur construise les imagettes sensibles
Mais l'affichage des fenètres stéréo correspondant à chaque image est ensuite quasi instantanné après clic sur l'image.
Il est possible de choisir dans le menu différents affichages stéréo. J'ai mis en parallèle par défaut.


ps: Connaissez vous les pages microstéréo de cet excellent micrographe qu'est Wim van Egmond?
http://www.microscop...rt98/milli.html
il a choisi la rusticité d'affichage en ne présentant que des anaglyphes mais c'est dommage de fausser ainsi quelque peu le rendu des couleurs.

Cordialement


Le StereoPhotoViewerApplet de Masuji SUTO fonctionne tout à fait bien dans ma configuration (avec firefox 3.6.1, et chrome, et le java implémenté sous linux). (Pour bien visualiser le relief en mode "cross eye" ou "parallel eyes", à quelle distance de l'écran faut-il se placer... ? je me trouverai des lunettes anaglyphes pour tester) et en plus le choix des procédés est très appréciable. (seul bémol, le menu de l'applet ne semble pas reconnaitre les accents mais c'est pas gênant pour fonctionner.)

A +
  • 0

#4 Michel

Michel

    Homo sapiens microscopicus

  • Membre confirmé
  • PipPipPipPipPipPipPipPipPipPip
  • 8 671 messages

Posté 12 octobre 2010 - 02:12

Bonjour,

MPX (ou son robot logiciel) écrit un code différent selon les navigateurs pour optimiser l'affichage de la page, mais cela provoque des erreurs et des disfonctionnements avec certains.

Je crois que tu te trompes.Il n'y a qu'un code sur le serveur, il n'y a pas plusieurs codes en fonction des navigateurs.
A la limite,on peut carrément se passer d'un éditeur HTML !*
Je me contente d'ajouter une entête et un pied de page et faire de la mise en page, c'est à dire de déplacer des blocs de code entiers sans toucher à leur contenu.En aucun cas mon logiciel ne va prendre l'initiative de modifier les données ou la présentation en fonction de navigateurs qui pour Chrome lui est inconnu !
Ce sont les navigateurs qui interprètent différemment le code que tu leur envoie et de plus comme le dit Jean,-Marie, les traitements de texte qui pondent de l'html, ne sont pas compatibles d'un continent à l'autre.
Dream se contente de signaler qu'une instruction n'est pas prise en charge par tel ou tel navigateur mais ne peut pas tenir compte de Chrome qui n'existait pas lors de la sortie de ma version.


Exemple :

Compatibilité.jpg


Bon, on ne va pas entammer un long débat sur ce point assez éloigné des préoccupations microscopiques, d'autant plus que le PDF semble plus simple à manier (pour moi!)

Cordialement.
  • 0

#5 Michel

Michel

    Homo sapiens microscopicus

  • Membre confirmé
  • PipPipPipPipPipPipPipPipPipPip
  • 8 671 messages

Posté 12 octobre 2010 - 02:37

Re,

J'ai remplacé dans la base le fichier Galster par le fichier modifié que tu m'as envoyé(Galster_modif1.htm)) et cela ne change rien aux constatations que j'avais faites.
A savoir, si on charge la galerie d'images directement dans un navigateur, on obtient des cadres sans images.(En l’occurrence 3 cadres vides sous Chrome)
Mais si l'on charge d'abord la première partie de l'article dans Chrome et que l'on clique dans cet article sur le lien qui conduit à la galerie, on obtient toutes les images (7).
Tout se passe comme si la bonne lecture de ses images était conditionné au passage par cette page, (et que le navigateur conserverait en mémoire certains chemins.)
  • 0

#6 adn25fr

adn25fr

    Purgatorius

  • Ex membre
  • PipPipPipPipPipPipPip
  • 786 messages

Posté 12 octobre 2010 - 03:52

Re,
j'ai refait vers 17h un essai sur chrome et miracle! de l'informatique? la page galster.htm s'affiche maintenant correctement et très rapidement.
C'est parfait. mPx n'a plus à intervenir pour moi.
Nous aurons appris qu'il utilise dreamweaver pour la mise en page .html et l'ajout des en tètes et bas de page spécifiques.
Michel, de quelle version s'agit il?

Je lis dans son dernier message que mPx a chargé la version chrome corrigée. Son intervention a du permettre cet affichage correct chez moi.


Pour les amateurs, voici le code d'affichage d'un script/image
<p> <applet code=petersik.stereo.stereoscope.Stereoscope.class
codebase="."
archive=stereoscope.jar
width=500
height=500
mayscript is necessary since stereoscope applet 1.3
alt="You must have a JAVA 1.1 compatible browser!" hspace="10">
<param name=stereoImage value="cajal/actino.jps">
<param name=prevImage value="cajal/actinobh3.jpg">
<param name=title value="Actinoptychus: diatomée test du relief au microscope">
<param name=viewType value="colorredcyan">
The preferred viewing method Now is some example text following which
is only displayed if the browser does not support JAVA
<p> <font color="#FF0000"> If you had a JAVA 1.1 enabled browser,
you would see a stereoscopic image here! <br>
So you get a preview only (not clickable, no 3D!): </font>
</applet></p>


on comprend que la mauvaise position de la balise </applet a des conséquenses...

Je ne comprend pas le problème rencontré par mPx. j'ai utilisé jusqu'à présent le lien de la page http://www.microscop...storiqueMAJ.htm
sans problème.

Pour répondre brièvement à Patrice, la vision stéréo en mode parallèle ou croisé nécessite un apprentissage. Je recommande d'utiliser de préférence un système de lunettes à prismes comme vendu par léman3D ou par loréo (voir le post de Gérard Weiss: http://www.lenatural...éoscopie#p21676
(Et le début du message ou je présente un système plus confortable compatible avec les applets cités.)

Cordialement
  • 0

#7 Michel

Michel

    Homo sapiens microscopicus

  • Membre confirmé
  • PipPipPipPipPipPipPipPipPipPip
  • 8 671 messages

Posté 12 octobre 2010 - 04:56

J'ai trouvé le bug.

En fait, il y a dans Microscopies 4 liens qui pointent sur la deuxième partie de l' article.(ainsi que 4 autres liens qui pointent sur la première partie)
Le lien que j'utilisais pointait sur un mauvais htm dans un dossier brouillon.
Ce qui explique qu'en utilisant, quel que soit l'un des 4 liens de la première partie de l'article, le lien en fin d'article propre à la première partie pointait sur le bon galster.htm et un des 4 liens directs sur le mauvais.

Pour Chrome, Daniel à certainement raison, c'était sûrement un problème d'emplacement de balises,
mais chrome n'existait pas au moment de la mise en ligne de l'article ce qui fait que le problème a échappé à notre attention.

Je pense que le sujet est clos.(mais on peut toujours le ré-ouvrir sur simple demande.)
  • 0

#8 L' Equipe Mikroscopia

L' Equipe Mikroscopia

    Homo sapiens microscopicus

  • L' Equipe de Mikroscopia
  • 1 130 messages

Posté 12 octobre 2010 - 04:58

Ce sujet est réglé.

Si vous avez une autre question, merci d'ouvrir un autre sujet.

L' Equipe des Modérateurs.
  • 0




N'oubliez pas de consulter notre Magazine en ligne ... MIK-MAG!